const regex = /, услуги,[^;]+;/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(', услуги,[^;]+;', 'g')
const str = `1. Иванов Иван Иванович - оказываются услуги проживания (2-х местный двухкомнатный Люкс, Основное место), услуги питания (Заказное меню), медицинские услуги (Лечение), услуги, связанные с организацией туристического путешествия; 2. Петров Пётр Петрович - оказываются услуги проживания (2-х местный двухкомнатный Люкс, Дополнительное место), услуги питания (Заказное меню), услуги, связанные с организацией туристического путешествия (без оказания медицинских услуг); 3. Семенов Семён Семёнович - оказываются медицинские услуги (Лечение), услуги, связанные с организацией туристического путешествия (без оказания услуг проживания, услуг питания);`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);