package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-ZÁÉÍÓÖŐÚÜŰ]([a-záéíóöőúüű]+\s?[\-\s\.]?\s?[A-Za-zÁÉÍÓÖŐÚÜŰáéíóöőúüű]*)$`)
var str = `Dr. Baranyi
Vörös Molnár
Venesz-Tak ács
Venesz - Takács
Hegyi
Válóczi
Nagyné Szendrei`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}