re = /^[A-ZÁÉÍÓÖŐÚÜŰ]([a-záéíóöőúüű]+\s?[\-\s\.]?\s?[A-Za-zÁÉÍÓÖŐÚÜŰáéíóöőúüű]*)$/m
str = 'Dr. Baranyi
Vörös Molnár
Venesz-Takács
Venesz - Takács
Hegyi
Válóczi
Nagyné Szendrei'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end