import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-ZÁÉÍÓÖŐÚÜŰ]([a-záéíóöőúüű]+\\s?[\\-\\s\\.]?\\s?[A-Za-zÁÉÍÓÖŐÚÜŰáéíóöőúüű]*)$";
final String string = "Dr. Baranyi\n"
+ "Vörös Molnár\n"
+ "Venesz-Takács\n"
+ "Venesz - Takács\n"
+ "Hegyi\n"
+ "Válóczi\n"
+ "Nagyné Szendrei";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}