const regex = /KOMM.: (.*?) /gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('KOMM.: (.*?) ', 'gm')
const str = `BRUTTO: 246.10, KOMM.: 3.40 ABR-NR: 525129 242.70 0 0.00 0 0 0 0 0
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}