// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)KOMM.: (.*?) ").unwrap();
let string = "BRUTTO: 246.10, KOMM.: 3.40 ABR-NR: 525129 242.70 0 0.00 0 0 0 0 0
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}