$re = '/KOMM.: (.*?) /m';
$str = 'BRUTTO: 246.10, KOMM.: 3.40 ABR-NR: 525129 242.70 0 0.00 0 0 0 0 0
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);