package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\/\w+\/?|\/\*\/?|\/\*\*\/?)+$`)
var str = `positive:
/foo/bar
/foo/bar/
/*
/foo/*
/foo/*/bar
/foo*
/**
/foo**
/foo/**
/foo/**/bar
negative:
foo
foo/bar
//foo
/foo//bar
/foo/***/bar
/***`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}