re = /^(?:\/\w+\/?|\/\*\/?|\/\*\*\/?)+$/m
str = 'positive:
/foo/bar
/foo/bar/
/*
/foo/*
/foo/*/bar
/foo*
/**
/foo**
/foo/**
/foo/**/bar
negative:
foo
foo/bar
//foo
/foo//bar
/foo/***/bar
/***'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end