package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<([l|L][i|I][n|N][k|K]).*?([h|H][r|R][e|E][f|F])(\s*?)=(\s*?)"(.*?)">`)
var str = `<link bla href="url"> gdfg fdg <link bla href="url"> `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}