import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<([l|L][i|I][n|N][k|K]).*?([h|H][r|R][e|E][f|F])(\\s*?)=(\\s*?)\"(.*?)\">";
final String string = "<link bla href=\"url\"> gdfg fdg <link bla href=\"url\"> ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}