$re = '/<([l|L][i|I][n|N][k|K]).*?([h|H][r|R][e|E][f|F])(\s*?)=(\s*?)"(.*?)">/m';
$str = '<link bla href="url"> gdfg fdg <link bla href="url"> ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);