using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=(?=(<Profile\b.*?<\/Profile>))<Profile\b.*?(?=(<limit>\w*?<\/limit>)))";
string input = @"<Profile sr=""prof101"" ve=""2"">
<flags>2</flags>
<Event sr=""con0"" ve=""2"">
</Event>
<limit>false</limit>
<App sr=""con1"" ve=""2"">
</App>
</Profile>
<Profile sr=""prof102"" ve=""2"">
<flags>2</flags>
<Event sr=""con0"" ve=""2"">
</Event>
<App sr=""con1"" ve=""2"">
</App>
</Profile>
<Profile sr=""prof103"" ve=""2"">
<flags>2</flags>
<limit>true</limit>
<Event sr=""con0"" ve=""2"">
</Event>
<limit>false</limit>
<limit>true</limit>
<App sr=""con1"" ve=""2"">
</App>
</Profile>
<Profile sr=""prof104"" ve=""2"">
<flags>2</flags>
<Event sr=""con0"" ve=""2"">
</Event>
<App sr=""con1"" ve=""2"">
</App>
</Profile>";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}