import Foundation
let pattern = #"(?<=(?=(<Profile\b.*?<\/Profile>))<Profile\b.*?(?=(<limit>\w*?<\/limit>)))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
<Profile sr="prof101" ve="2">
<flags>2</flags>
<Event sr="con0" ve="2">
</Event>
<limit>false</limit>
<App sr="con1" ve="2">
</App>
</Profile>
<Profile sr="prof102" ve="2">
<flags>2</flags>
<Event sr="con0" ve="2">
</Event>
<App sr="con1" ve="2">
</App>
</Profile>
<Profile sr="prof103" ve="2">
<flags>2</flags>
<limit>true</limit>
<Event sr="con0" ve="2">
</Event>
<limit>false</limit>
<limit>true</limit>
<App sr="con1" ve="2">
</App>
</Profile>
<Profile sr="prof104" ve="2">
<flags>2</flags>
<Event sr="con0" ve="2">
</Event>
<App sr="con1" ve="2">
</App>
</Profile>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)