const regex = new RegExp('(?<=(?=(<Profile\\b.*?<\\/Profile>))<Profile\\b.*?(?=(<limit>\\w*?<\\/limit>)))', 'gs')
const str = `<Profile sr="prof101" ve="2">
<flags>2</flags>
<Event sr="con0" ve="2">
</Event>
<limit>false</limit>
<App sr="con1" ve="2">
</App>
</Profile>
<Profile sr="prof102" ve="2">
<flags>2</flags>
<Event sr="con0" ve="2">
</Event>
<App sr="con1" ve="2">
</App>
</Profile>
<Profile sr="prof103" ve="2">
<flags>2</flags>
<limit>true</limit>
<Event sr="con0" ve="2">
</Event>
<limit>false</limit>
<limit>true</limit>
<App sr="con1" ve="2">
</App>
</Profile>
<Profile sr="prof104" ve="2">
<flags>2</flags>
<Event sr="con0" ve="2">
</Event>
<App sr="con1" ve="2">
</App>
</Profile>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}