const regex = /^(5[1-9]|[6-9][0-9]|100)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(5[1-9]|[6-9][0-9]|100)$', 'gm')
const str = `50
51
60
61
65
70
75
80
85
90
99
100
101
200`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}