$re = '/^(5[1-9]|[6-9][0-9]|100)$/m';
$str = '50
51
60
61
65
70
75
80
85
90
99
100
101
200';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);