re = /^(5[1-9]|[6-9][0-9]|100)$/m
str = '50
51
60
61
65
70
75
80
85
90
99
100
101
200'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end