#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\S+)=["']?((?:.(?!["']?\s+(?:\S+)=|\s*\/?[>"']))+.)["']?"
Local $sString = "<a href=test.html class=xyz>" & @CRLF & _
"<a href="test.html" class="xyz">" & @CRLF & _
"<a href='test.html' class="xyz">" & @CRLF & _
"<script type="text/javascript" defer async id="something" onload="alert('hello');"></script>" & @CRLF & _
"<img src="test.png">" & @CRLF & _
"<img src="a test.png">" & @CRLF & _
"<img src=test.png />" & @CRLF & _
"<img src=a test.png />" & @CRLF & _
"<img src=test.png >" & @CRLF & _
"<img src=a test.png >" & @CRLF & _
"<img src=test.png alt=crap >" & @CRLF & _
"<img src=a test.png alt=crap >"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")