import re
regex = re.compile(r"(\S+)=[\"']?((?:.(?![\"']?\s+(?:\S+)=|\s*\/?[>\"']))+.)[\"']?", flags=re.MULTILINE)
test_str = ("<a href=test.html class=xyz>\n"
"<a href=\"test.html\" class=\"xyz\">\n"
"<a href='test.html' class=\"xyz\">\n"
"<script type=\"text/javascript\" defer async id=\"something\" onload=\"alert('hello');\"></script>\n"
"<img src=\"test.png\">\n"
"<img src=\"a test.png\">\n"
"<img src=test.png />\n"
"<img src=a test.png />\n"
"<img src=test.png >\n"
"<img src=a test.png >\n"
"<img src=test.png alt=crap >\n"
"<img src=a test.png alt=crap >")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")