using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\S+)=[""']?((?:.(?![""']?\s+(?:\S+)=|\s*\/?[>""']))+.)[""']?";
string input = @"<a href=test.html class=xyz>
<a href=""test.html"" class=""xyz"">
<a href='test.html' class=""xyz"">
<script type=""text/javascript"" defer async id=""something"" onload=""alert('hello');""></script>
<img src=""test.png"">
<img src=""a test.png"">
<img src=test.png />
<img src=a test.png />
<img src=test.png >
<img src=a test.png >
<img src=test.png alt=crap >
<img src=a test.png alt=crap >";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}