package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\\:]`)
var str = `By: <span style='background-color:#ffc8c4;'>Anita</span> <span style='background-color:#ffc8c4;'>Elberse</span> and Sir Alex Ferguson`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}