re = /[\\:]/
str = 'By: <span style=\'background-color:#ffc8c4;\'>Anita</span> <span style=\'background-color:#ffc8c4;\'>Elberse</span> and Sir Alex Ferguson'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end