$re = '/[\\\\:]/';
$str = 'By: <span style=\'background-color:#ffc8c4;\'>Anita</span> <span style=\'background-color:#ffc8c4;\'>Elberse</span> and Sir Alex Ferguson';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);