use strict;
my $str = 'root/12-825-ReturnAndStatsCompositeAPI[v="timeSeries-return",g="timeSeries",p="{"rollingPeriod":"1Y","numberOfPeriods":"5","asOfDate":"2016-12-31","startDate":"2011-12-31","frequency":"1Y"}"]/data/share_classes/array[1]/returns_series/returns/array[1]/net/cumulative
root/2-825-ReturnAndStatsCompositeAPI[v="timeSeries-benchmark",g="timeSeries",p="{"rollingPeriod":"1Y","column":"column","numberOfPeriods":"5","asOfDate":"2016-12-31","startDate":"2011-12-31","frequency":"1Y"}"]/data/share_classes/array[1]/benchmark_types/benchmark_types_breakdown/array[3]/returns_series/returns/array[1]/gross/annualized
root/2-825-ReturnAndStatsCompositeAPI[v="timeSeries-benchmark",g="timeSeries",p="{"rollingPeriod":"1Y","column":"column","numberOfPeriods":"5","asOfDate":"2016-12-31","startDate":"2011-12-31","frequency":"1Y"}"]/data/share_classes/array[1]/benchmark_types/benchmark_types_breakdown/array[3]/mpt_statistics_series/relative/gross/array[1]/excess_return
';
my $regex = qr/\S+\[v=\"(timeSeries)-(\w+)\",g=\"(\w+)\",p=\"(\S+)\"\]\S+array\[(\d+)\]\/(\S+)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}