import re
regex = re.compile(r"\S+\[v=\"(timeSeries)-(\w+)\",g=\"(\w+)\",p=\"(\S+)\"\]\S+array\[(\d+)\]\/(\S+)")
test_str = ("root/12-825-ReturnAndStatsCompositeAPI[v=\"timeSeries-return\",g=\"timeSeries\",p=\"{\"rollingPeriod\":\"1Y\",\"numberOfPeriods\":\"5\",\"asOfDate\":\"2016-12-31\",\"startDate\":\"2011-12-31\",\"frequency\":\"1Y\"}\"]/data/share_classes/array[1]/returns_series/returns/array[1]/net/cumulative\n\n"
"root/2-825-ReturnAndStatsCompositeAPI[v=\"timeSeries-benchmark\",g=\"timeSeries\",p=\"{\"rollingPeriod\":\"1Y\",\"column\":\"column\",\"numberOfPeriods\":\"5\",\"asOfDate\":\"2016-12-31\",\"startDate\":\"2011-12-31\",\"frequency\":\"1Y\"}\"]/data/share_classes/array[1]/benchmark_types/benchmark_types_breakdown/array[3]/returns_series/returns/array[1]/gross/annualized\n\n"
"root/2-825-ReturnAndStatsCompositeAPI[v=\"timeSeries-benchmark\",g=\"timeSeries\",p=\"{\"rollingPeriod\":\"1Y\",\"column\":\"column\",\"numberOfPeriods\":\"5\",\"asOfDate\":\"2016-12-31\",\"startDate\":\"2011-12-31\",\"frequency\":\"1Y\"}\"]/data/share_classes/array[1]/benchmark_types/benchmark_types_breakdown/array[3]/mpt_statistics_series/relative/gross/array[1]/excess_return\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")