#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)\d\d[A-Z]?(?:\s*(?:and|or|,)\s*\d\d[A-Z]?)*"
Local $sString = "biscuits 10 are good" & @CRLF & _
"biscuits 20 and 30 are good" & @CRLF & _
"biscuits 40 and hot dog are good" & @CRLF & _
"but this one 50A and 50B and not ok"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")