import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d\\d[A-Z]?(?:\\s*(?:and|or|,)\\s*\\d\\d[A-Z]?)*";
final String string = "biscuits 10 are good\n"
+ "biscuits 20 and 30 are good\n"
+ "biscuits 40 and hot dog are good\n"
+ "but this one 50A and 50B and not ok";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}