re = /\d\d[A-Z]?(?:\s*(?:and|or|,)\s*\d\d[A-Z]?)*/mx
str = 'biscuits 10 are good
biscuits 20 and 30 are good
biscuits 40 and hot dog are good
but this one 50A and 50B and not ok'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end