using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b100\b";
string substitution = @"200";
string input = @"100 1100 1000";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}