// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\b100\b").unwrap();
let string = "100 1100 1000";
let substitution = "200";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}