const regex = /\b100\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b100\\b', 'g')
const str = `100 1100 1000`;
const subst = `200`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);