import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=\\s|)(آپ)(?=\\s|$)";
final String string = "آپ\n"
+ "آپ کا نام کیا ہے؟\n"
+ "آپ کا نام کیا ہے؟ آپ کا نام کیا ہے؟\n"
+ "آپکاآپکا نام کیا ہے؟آپکا نام کیا ہے؟";
final String subst = "app";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}