$re = '/(?=\s|)(آپ)(?=\s|$)/m';
$str = 'آپ
آپ کا نام کیا ہے؟
آپ کا نام کیا ہے؟ آپ کا نام کیا ہے؟
آپکاآپکا نام کیا ہے؟آپکا نام کیا ہے؟';
$subst = "app";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;