const regex = /\b\d{4}\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b\\d{4}\\b', 'g')
const str = `Your otp for the login is 7832. This code will expire at 12:43:09PM`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}