re = /\b\d{4}\b/
str = 'Your otp for the login is 7832. This code will expire at 12:43:09PM'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end