$re = '/\b\d{4}\b/';
$str = 'Your otp for the login is 7832. This code will expire at 12:43:09PM';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);