using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=required)\s:\s+\'(.+)\',|(?<=dateISO)\s:\s+\'(.+)\'";
string input = @"{ messages : { required : 'This 'asdf' ""asdf"" field is required!', dateISO : 'This is a test...' } , rules : { dateISO : true , required : true } }";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}