import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=required)\\s:\\s+\\'(.+)\\',|(?<=dateISO)\\s:\\s+\\'(.+)\\'";
final String string = "{ messages : { required : 'This 'asdf' \"asdf\" field is required!', dateISO : 'This is a test...' } , rules : { dateISO : true , required : true } }";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}