re = /(?<=required)\s:\s+\'(.+)\',|(?<=dateISO)\s:\s+\'(.+)\'/
str = '{ messages : { required : \'This \'asdf\' "asdf" field is required!\', dateISO : \'This is a test...\' } , rules : { dateISO : true , required : true } }'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end