package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\S+(?:\s\S+)*`)
var str = `Appl.No Date/Hour Mass (g ai.ha-1) Areic mean deposition (mg.m-2)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}