// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\S+(?:\s\S+)*").unwrap();
let string = "Appl.No Date/Hour Mass (g ai.ha-1) Areic mean deposition (mg.m-2)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}