$re = '/(?: |^)\w+(-)(?![0-9])\w+/m';
$str = 'Jean-Pierre bought "blue-green-red" product-2345 and other blue-red stuff.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);