re = /(?: |^)\w+(-)(?![0-9])\w+/m
str = 'Jean-Pierre bought "blue-green-red" product-2345 and other blue-red stuff.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end