package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^[\w:,\/()-]{10,50}$`)
var str = `12345677889
adsda asd
nnn-nnnnnnnn
asdasdA_asdasdasdsadsadasdsadasdasdasdasdasdasdasdasda
asdas_asdasdas
011-45538691/92/93`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}