re = /^[\w:,\/()-]{10,50}$/im
str = '12345677889
adsda asd
nnn-nnnnnnnn
asdasdA_asdasdasdsadsadasdsadasdasdasdasdasdasdasdasda
asdas_asdasdas
011-45538691/92/93'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end