// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)^[\w:,\/()-]{10,50}$").unwrap();
let string = "12345677889
adsda asd
nnn-nnnnnnnn
asdasdA_asdasdasdsadsadasdsadasdasdasdasdasdasdasdasda
asdas_asdasdas
011-45538691/92/93";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}