$re = '/^(?=.{6,20}$)(?:[a-zA-Z\d]+(?:(?:\.|-|_)[a-zA-Z\d])*)+$/m';
$str = 'rubi
rubin1
_rubin
.rubin
rubin_
rubin.1
rubin12
rubin12
rubin.12
r12fgj
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);