import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<script([^>]*)?>.*?<\\/script>";
final String string = "<p>Hello</p><script type=\"text/javascript\">const x = 29; console.log('Hello world');</script><p>World</p><script>alert('Hello world');</script><script src=\"javascript.js\"></script>";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}