import Foundation
let pattern = #"<script([^>]*)?>.*?<\/script>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"<p>Hello</p><script type="text/javascript">const x = 29; console.log('Hello world');</script><p>World</p><script>alert('Hello world');</script><script src="javascript.js"></script>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)